[Sidefx-houdini-list] two keyframed expressions on a single parameter

Tom Nixon ignivomous at gmail.com
Wed May 25 01:54:09 EDT 2011


I think that the keyframes have always been the first frame of a given
scene. So it would appear that I was doing dev work in a scene that started
on frame 1 and then frame 17. Eventually I would find that my expression has
been saved as two separate keyframes on each start frame. I am not able to
reproduce this simply by changing the start frame, though. Lately, almost
all of my expressions have been python, but I'm pretty sure that I've had
this happen with hscript expressions too.

On this show, we have been staying with the same version of houdini through
90% of production. I'm sure that most of the otls that have exhibited this
have been developed in the same version of Houdini.

I will see if I can dig up an old version of an otl with two expressions
when I get to work.

Thanks!
Tom
On Wed, May 25, 2011 at 4:21 AM, Edward Lam <edward at sidefx.com> wrote:

> Have you noticed if there is any correlation with where these extra keys
> come up? eg. like the frame at the end of shot or something like that.
> Maybe there's something that is triggering extra keys? Feel free to send
> me the .hip file privately (with HDA embedded) where this has happened.
> Are you switching between using the .hip files between different major
> versions of Houdini?
>
> -Edward
>
> On Tue, May 24, 2011 10:25, Pablo Giménez wrote:
> > No Tom you are not crazy.
> > Thsi has happened to me lot of times, a really annoying problem.
> > I think would be nice to have an option in the preferences to avoid
> having
> > keyframes and expressions in the same channel.
> > Most of the times is an error.
> >
> >
> > 2011/5/20 Tom Nixon <ignivomous at gmail.com>
> >
> >> Hey all,
> >>
> >> It seems at work as though I'm the only person who accidentally creates
> >> multiple keyframed expressions in my parameters on different frames when
> >> working with OTLs. This will usually be caught after wasting a day
> >> trying
> >> to
> >> figure out why something is breaking only to discover that there is a
> >> keyframed expression on frame 17 that does not work any longer and the
> >> new
> >> functional expression is at frame 0.
> >>
> >> My coworkers are probably starting to think I'm insane. Does anyone else
> >> ever have this happen? Does anyone know what is causing this to happen
> >> (as
> >> I
> >> have not yet been able to reproduce this intentionally)?
> >>
> >> Thanks,
> >> Tom
> >> _______________________________________________
> >> Sidefx-houdini-list mailing list
> >> Sidefx-houdini-list at sidefx.com
> >> https://lists.sidefx.com:443/mailman/listinfo/sidefx-houdini-list<https://lists.sidefx.com/mailman/listinfo/sidefx-houdini-list>
> >>
> >
> >
> >
> > --
> > Un saludo
> > Best Regards
> > Pablo Giménez
> > _______________________________________________
> > Sidefx-houdini-list mailing list
> > Sidefx-houdini-list at sidefx.com
> > https://lists.sidefx.com:443/mailman/listinfo/sidefx-houdini-list<https://lists.sidefx.com/mailman/listinfo/sidefx-houdini-list>
> >
>
>
> _______________________________________________
> Sidefx-houdini-list mailing list
> Sidefx-houdini-list at sidefx.com
> https://lists.sidefx.com:443/mailman/listinfo/sidefx-houdini-list<https://lists.sidefx.com/mailman/listinfo/sidefx-houdini-list>
>



More information about the Sidefx-houdini-list mailing list