[Sidefx-houdini-list] tcsh: Undefined variable - houdini.setup

Peter Bowmar pbowmar at gmail.com
Sat Oct 30 01:00:04 EDT 2010


Hey Floyd,

I don't have Linux in front of me this second, but if you run "tcsh
-h" or something like that, take a look at the flags to tcsh and one
of them is a "debug mode" that will echo each line as it executes it.
This will help track down what line is causing the problem, perhaps
narrowing it down...

Cheers,


Peter B

On 29 October 2010 21:22, Floyd Gillis <floyd at afcg.com> wrote:
> This is probably more of a linux question...
>
> Am working (and have always worked) in tcsh.
>
> Had to rebuild my linux system yesterday... still tweaking and
> fine-tuning... but am having a strange problem when I try to source
> houdini.setup from a shell.  I now get a "tcsh: Undefined variable"
> error message.  I can source houdini.setup from the command line without
> any errors.  I'm sure something has changed in linux because even my
> scripts for houdini 10 now give the same error message.
>
> I've always ran my render shells from the command line like so... "csh
> render.sh"... and this shell would then run other executable shells that
> sourced houdini.setup without any problem.  All my shells have
> "#!/bin/csh -f" as their first line.
>
> I'm finding limited success when I change the first line of the shells
> to "#!/bin/tcsh -f" or run shells from the command line with "tcsh
> render.sh" rather than "csh render.sh"... which kind of makes sense...
> but again... was never necessary before.
>
> Anyone else come across this?
>
> h11.0.547
> KDE: 3.5.10
> System/Release: Debian Linux 2.6.26-2-amd64
> Machine: x86_64
>
> Thanks,
>
> Floyd
>
>
> _______________________________________________
> Sidefx-houdini-list mailing list
> Sidefx-houdini-list at sidefx.com
> https://lists.sidefx.com:443/mailman/listinfo/sidefx-houdini-list
>



-- 
No, I am not on Facebook.



More information about the Sidefx-houdini-list mailing list