[Sidefx-houdini-list] tcsh: Undefined variable - houdini.setup

Floyd Gillis floyd at afcg.com
Sat Oct 30 00:22:12 EDT 2010


This is probably more of a linux question...

Am working (and have always worked) in tcsh.

Had to rebuild my linux system yesterday... still tweaking and 
fine-tuning... but am having a strange problem when I try to source 
houdini.setup from a shell.  I now get a "tcsh: Undefined variable" 
error message.  I can source houdini.setup from the command line without 
any errors.  I'm sure something has changed in linux because even my 
scripts for houdini 10 now give the same error message.

I've always ran my render shells from the command line like so... "csh 
render.sh"... and this shell would then run other executable shells that 
sourced houdini.setup without any problem.  All my shells have 
"#!/bin/csh -f" as their first line.

I'm finding limited success when I change the first line of the shells 
to "#!/bin/tcsh -f" or run shells from the command line with "tcsh 
render.sh" rather than "csh render.sh"... which kind of makes sense... 
but again... was never necessary before.

Anyone else come across this?

h11.0.547
KDE: 3.5.10
System/Release: Debian Linux 2.6.26-2-amd64
Machine: x86_64

Thanks,

Floyd





More information about the Sidefx-houdini-list mailing list