[Sidefx-houdini-list] Material path stuck on Primitive attributes-

Mark Elendt mark at sidefx.com
Tue Nov 2 11:06:06 EDT 2010


You might try the:
    vm_overridedetail
property.  Oh wait, this isn't your problem.

Were you adding the same type of material attributes on the geometry?
Was one perhaps the old style "shop_vm_surface" instead of
"shop_materialpath"?  I'd probably have to know a little more about
the geometry file and the attributes that were there, but it seems
that the old shop_vm_surface could throw a wrench in the works.

On Tuesday Nov 02 at 10:30, Jed Schwartz wrote:
> Is there a simple way to clear all primitive attributes from an  
> object-? I just had a situation where  I could not re-assign a  
> material to an object on the SOP level- It appears that the material  
> imbedded in the primitive atts can not be over-ridden, any new  
> material path is ignored and when rendered, the surface shader is  
> stuck on some imbedded shader. I had to save out the geo as a .poly   
> to strip it clean- When I read it back in, all works as expected when  
> assigning a new material-
> 
> I'm sure I'm missing something obvious-- my problem is solved, but  
> I'm curious to know what's going on..?
> 
> Thanks,
> 
> Jed-
> 
> jed at jedschwartz.com
> http://www.jedschwartz.com
> 
> _______________________________________________
> Sidefx-houdini-list mailing list
> Sidefx-houdini-list at sidefx.com
> https://lists.sidefx.com:443/mailman/listinfo/sidefx-houdini-list

-- 
Mark Elendt



More information about the Sidefx-houdini-list mailing list