[Sidefx-houdini-list] ray sop fetching attribute values that dont exist.

Andrew D Lyons tstexture at gmail.com
Mon Feb 1 17:48:45 EST 2010


How many samples are you using? Are you using "average Ray" as the
combiner?You may be averaging multiple samples to get 0.

If you play with some of those settings you may get more desirable
results. ie. 5 samples and "longest ray".

Cheers

On 1 February 2010 14:39, Robert Kelly <isstuff at gmail.com> wrote:
> I am wondering if the ray sop can be trusted....
>
> I have a ray sop fetching attributes from some geometry but sometimes
> it returns values that are not there to be returned.
>
> I have an int attribute called curve and it is on 7 tubes the
> attribute goes from 1 to 7 according to the curve that each tube was
> made from. The value is never zero. so i take that geometry append a
> attributeCreate set the curve int value to -1. I put it into the first
> input of a ray sop and the geometry before the attributeCreate into
> the second input; I set the bias so it dosen't just get the same point
> it came from... i set the ray sop to return the curve attribute that
> it hits and the dist value.
>
> So i am getting Zero for some of the curve attributes, there are
> plenty of -1 values for all the points that miss, and some values from
> 1-7 for others that hit but some have 0 as the value. What could cause
> this?
>
> Any ideas?
> Robert Kelly
> _______________________________________________
> Sidefx-houdini-list mailing list
> Sidefx-houdini-list at sidefx.com
> https://lists.sidefx.com:443/mailman/listinfo/sidefx-houdini-list
>



-- 
=======================================
Andrew D Lyons | Digital Artist | http://www.tstex.com
=======================================



More information about the Sidefx-houdini-list mailing list