[Sidefx-houdini-list] [HOM] Setting a float attribute value on a point

Peter Bowmar pbowmar at gmail.com
Wed Jan 30 04:41:23 EST 2008


Might be a goofy Python thing where it expects a "tuple" so if it's a
single value, put a comma at the end like:

setAttribValue(f,1.0,)

Note that I'm guessing wildly here.

Cheers,

PeterB

On 30/01/2008, Olex P <hoknamahn at gmail.com> wrote:
> Hey Andras,
> I've found the same problem: setAttr() works fine say for two floats but not
> for one.
> Hope someone can explain why...
>
> On Jan 29, 2008 6:32 PM, Andras Ikladi <andras.ikladi at gmail.com> wrote:
>
> > Hey,
> >
> > I'm having a problem with $SUBJECT
> > ..at least I can't get my head around this. Should be simple.
> >
> > First I create two attributes on the geo, both of them initializes
> > properly
> > with these values:
> >
> > ...addAttrib(hou.attribType.Point, "v", (0.0, 1.0, 0.0))
> > ...addAttrib(hou.attribType.Point, "f", 10.1)
> >
> >
> > Then trying to set values per point in a loop
> > This works (hou.Color works too):
> > ...setAttribValue(v, hou.Vector3(1,2,3))
> >
> > But this doesn't:
> > ...setAttribValue(f,1.0)
> >
> > What am I doing wrong? (I did read the doc :D)
> >
> > Thanks,
> > Andras
> > _______________________________________________
> > Sidefx-houdini-list mailing list
> > Sidefx-houdini-list at sidefx.com
> > https://lists.sidefx.com:443/mailman/listinfo/sidefx-houdini-list
> >
> _______________________________________________
> Sidefx-houdini-list mailing list
> Sidefx-houdini-list at sidefx.com
> https://lists.sidefx.com:443/mailman/listinfo/sidefx-houdini-list
>



More information about the Sidefx-houdini-list mailing list