[Sidefx-houdini-list] Attributes going nuts

Sean Lewkiw seanl at rainmaker.com
Thu Oct 25 11:25:57 EDT 2007


Out of curiosity, why are you using $ID as a lookup?  I think if you use 
$PT it should work.

I've only ever used $ID in the poppoint expression.

Sean

Andy Nicholas wrote:
> Hi guys,
>
> Has anyone else had funny experiences with point attributes?
>
> I've got some particles and they have a point attribute called clr[3] (I'm
> using it with the Contant shader which is why it's not Cd). What I'm
> finding is that the following expressions:
>
> point("../attribcreate1",$ID,"clr",0)
> point("../attribcreate1",$ID,"clr",1)
> point("../attribcreate1",$ID,"clr",2)
>
>
> aren't giving the correct values in a Point node further down the network
> when I'm trying to modify these values.
>
> I've also tried something as basic as copying the clr[3] attribute to a
> new attribute (using the Attribute Create node) with the same expression,
> and it still fails to give anything sensible. If you view the original
> clr[3] attribute with the newly created  attribute in spreadsheet, they
> have totally different values!
>
> I'm on a deadline so I need to solve this asap! I'm using Houdini 8.2.58,
> is this a bug? Are there any workarounds?
>
> Thanks!
>
> Andy
>
>
>
> _______________________________________________
> Sidefx-houdini-list mailing list
> Sidefx-houdini-list at sidefx.com
> https://lists.sidefx.com:443/mailman/listinfo/sidefx-houdini-list
>   

-- 
Sean Lewkiw
--
Rainmaker Digital
130 Shaftesbury Avenue
London W1D 5EU
--
+44 (0) 207.031.1138 (P) (Direct)
+44 (0) 207.031.1136 (F)
+44 (0) 795.606.7245 (M)





More information about the Sidefx-houdini-list mailing list