[Sidefx-houdini-list] mantra in H9 - multiprocessor

Dan Schneider eyevex at yahoo.com
Mon Oct 8 11:35:12 EDT 2007


We have been encountering similar issues in H9. I don't think it has to do with HT either. It occurs with the default max proc checked on one of our quadcore xeon machines, but not on the duo core xeons.  Issue ranges to mantra crashing all together. But, if 2 or less threads are used it goes fine, as it has been mentioned. Only when using over 2. What build is everyone using? We are using 9.0.719. 

Larry Giunta <larry at gcreativestudios.com> wrote: actually, I'm simply clicking off max proc and
manually entering thread numbers ........
so I'm not manually changing any options.

No hyperthreading enabled either -

However, here's something curious, Mark E.

If I copy and paste an output node from H8 into
H9, then specify 4 processors, the render tile
just blast up as quickly as expected and
the render completes much faster than the
H9 output driver in the same houdini session.

So, it seems to point to some setting or option
within the H9 output node.

Here are the times I get now. Both rendering
within H9 ( same object, etc) , but with the first using a pasted H8
output node.

------------------------------------------------------
4 thread H8 output node pasted into H9
1.34u 0.80s 5.76r


4 thread H9 output node in H9
1:08.70u 0.55s 17.80r
------------------------------------------------------



On Oct 5, 2007, at 4:46 PM, Mark Elendt wrote:

> On Friday Oct 05 at 16:12, Larry Giunta wrote:
>> So, we've seemed to narrow down our slow mantra render problem
>> in H9 to multiprocessor rendering.
>
> You are using the new -j option?  Not the -n?
>
> By default mantra will be using all your processors.  If you happen to
> be using the old -n multi-host way of adding machines, you'll in fact
> be running 16 threads on a 4 processor system (using -n4).
>
> Just a sanity check...
>
>> If we render on only one proc, render times seems as fast as  
>> expected.
>> However, with each increase to the thread count our render times get
>> increasingly slow.
>> The system monitor does show the appropriate number of processors
>> working.
>>
>> On the same machine multiprocessor rendering works just fine in  
>> H8, but
>> in H9 we get the following time increase with each thread added.
>>
>> We're running 9.0.739 on FC4
>>
>> Wondering if anyone else is getting similar results  ......... or if
>> this is just unique for us.
>>
>> Larry
>>
>> -----------------------------------------------
>> 1 thread
>> 9.01u 0.38s 9.02r
>>
>> 2 thread
>> 15.15u 0.42s 7.77r
>>
>> 3 thread
>> 56.13u 0.56s 19.02r
>>
>> 4 thread
>> 2:13.80u 0.64s 33.96r
>> -----------------------------------------------
>
> _______________________________________________
> Sidefx-houdini-list mailing list
> Sidefx-houdini-list at sidefx.com
> https://lists.sidefx.com:443/mailman/listinfo/sidefx-houdini-list

_______________________________________________
Sidefx-houdini-list mailing list
Sidefx-houdini-list at sidefx.com
https://lists.sidefx.com:443/mailman/listinfo/sidefx-houdini-list


       
---------------------------------
Fussy? Opinionated? Impossible to please? Perfect.  Join Yahoo!'s user panel and lay it on us.


More information about the Sidefx-houdini-list mailing list